Pàgina d'inici » Office » Excel 2013 (365) » Excel 2013 / 365: Crear una llista combinació de altres 2.

Excel 2013 / 365: Crear una llista combinació de altres 2.

Tradueix la pàgina

USA Flag German Flag Spain Flag
USA Flag German Flag Spain Flag
Excel
Microsoft Excel

Com generar una llista que sigui la combinació de 2 llistes (sense VBA).

Que el “Visual Basic for Applications” (VBA) permet fer cosses molt interessants amb Excel es una evidència.

Però que passa si no vull (o no se) programar?

Com puc combinar 2 taules i generar totes les combinacions?

Com puc fer-ho sense programar?

Doncs aquí et mostro una opció per a fer-ho (i a més en múlti-idioma).

 

Descripció Exemple
Condicions:

Tens 2 taules als rangs A1:A4 i B1:B3 que vols combinar

Rang exemple


code example
Resultat
Spanish:

=SI(
(FILA()-FILA($D$1)+1)>CONTARA($A$1:$A$4)*CONTARA($B$1:$B$3);
"buit";
INDICE($A$1:$A$4;ENTERO((FILA()-FILA($D$1))/CONTARA($B$1:$B$3)+1))&
"-" &
INDICE($B$1:$B$3;RESIDUO(FILA()-FILA($D$1);CONTARA($B$1:$B$3))+1)
)
s s
s s

 

 

 

 

 

 

 

Advertisements

Deixa un comentari

Fill in your details below or click an icon to log in:

WordPress.com Logo

Esteu comentant fent servir el compte WordPress.com. Log Out / Canvia )

Twitter picture

Esteu comentant fent servir el compte Twitter. Log Out / Canvia )

Facebook photo

Esteu comentant fent servir el compte Facebook. Log Out / Canvia )

Google+ photo

Esteu comentant fent servir el compte Google+. Log Out / Canvia )

Connecting to %s

%d bloggers like this: