Pàgina d'inici » Office

Category Archives: Office

Excel 2013 / 365: Crear una llista combinació de altres 2.

USA Flag German Flag Spain Flag
Excel
Microsoft Excel

Com generar una llista que sigui la combinació de 2 llistes (sense VBA).

Que el “Visual Basic for Applications” (VBA) permet fer cosses molt interessants amb Excel es una evidència.

Però que passa si no vull (o no se) programar?

Com puc combinar 2 taules i generar totes les combinacions?

Com puc fer-ho sense programar?

Doncs aquí et mostro una opció per a fer-ho (i a més en múlti-idioma).

 

Descripció Exemple
Condicions:

Tens 2 taules als rangs A1:A4 i B1:B3 que vols combinar

Rang exemple


code example
Resultat
Spanish:

=SI(
(FILA()-FILA($D$1)+1)>CONTARA($A$1:$A$4)*CONTARA($B$1:$B$3);
"buit";
INDICE($A$1:$A$4;ENTERO((FILA()-FILA($D$1))/CONTARA($B$1:$B$3)+1))&
"-" &
INDICE($B$1:$B$3;RESIDUO(FILA()-FILA($D$1);CONTARA($B$1:$B$3))+1)
)
s s
s s

 

 

 

 

 

 

 

Excel 2013: recomptar / sumar condicionalment

USA Flag German Flag Spain Flag
Excel
Microsoft Excel

Excel 2013: Sumes / comptadors condicionals

Una de les funcions més interessants que afegeix Excel son les sumes i comptadors condicionals, es a dir, comptar el nombre de cel·les que incorporen una certa condició.

Exemple: COUNTIF, SUMIF, COUNTIFS, SUMIFS

Les funcions COUNTIFS, SUMIFS son les versions amb múltiples condicions de COUNTIF, SUMIF
Algunes notes interessants:

  • Aquestes funcions no son "case-sensitive", es a dir, entenen que es ho mateix "EXEMPLE" que "exemple"
  • Si les condicions les vols vinculades a una cel·la modificable (cosa molt més útil) cal afegir & a la referència.

Veiem un cas:

Descripció Exemple
Suposem que vols recomptar tot allò que:

  • sigui del àrea “App” i
  • tingui més de 2 punts (“Límit grup superior”).

 

Excel example

Excel COUNTIFS, SUMIFS

COUNTIFS:
COUNTIFS(rang_criteri_1, criteri_a_complir_1, [rang_criteri_2, criteri_a_complir_2]…)

Els rangs de cada criteri poden ser diferents.

Observa també al exemple el & que cal incorporar als condicionals vinculats a la cel·la modificable.

=COUNTIFS('Concentració Areas'!A:A;"="&E4;C:C;">="&F4)
SUMIFS:

Igual que COUNTIFS però afegeix al principi el rang a sumar si les condicions s’acompleixen.

=SUMIFS(C:C;'Concentració Areas'!A:A;"="&E4;C:C;">="&F4)

 

Enllaços relacionats:

 

Altres temes dels que parlo:


Excel 365, Excel 2013: Creació de plantilles personals

Cloud computing: Enderrocant 10 mites

Incidents de Seguretat: I ara que faig? Com responc?






 

%d bloggers like this: