Pàgina d'inici » Programació

Category Archives: Programació

Excel 2013 / 365: Crear una llista combinació de altres 2.

USA Flag German Flag Spain Flag
Excel
Microsoft Excel

Com generar una llista que sigui la combinació de 2 llistes (sense VBA).

Que el “Visual Basic for Applications” (VBA) permet fer cosses molt interessants amb Excel es una evidència.

Però que passa si no vull (o no se) programar?

Com puc combinar 2 taules i generar totes les combinacions?

Com puc fer-ho sense programar?

Doncs aquí et mostro una opció per a fer-ho (i a més en múlti-idioma).

 

Descripció Exemple
Condicions:

Tens 2 taules als rangs A1:A4 i B1:B3 que vols combinar

Rang exemple


code example
Resultat
Spanish:

=SI(
(FILA()-FILA($D$1)+1)>CONTARA($A$1:$A$4)*CONTARA($B$1:$B$3);
"buit";
INDICE($A$1:$A$4;ENTERO((FILA()-FILA($D$1))/CONTARA($B$1:$B$3)+1))&
"-" &
INDICE($B$1:$B$3;RESIDUO(FILA()-FILA($D$1);CONTARA($B$1:$B$3))+1)
)
s s
s s

 

 

 

 

 

 

 

Anuncis

SQL: Guia visual de SQL Joins

USA Flag Spain Flag German Flag

Guia visual de SQL Joins

Via codejobs.biz he trobat aquest resum gràfic de com muntar les diferents sentencies SQL que m’ha semblat molt interessant com a eina didàctica.

SQL Join picture

SQL Join (from codejobs.biz) – Click per ampliar –

 

Altres temes dels que parlo:


DevOps o com recuperar la visió global de IS

GAMP, 21CFR part11 … i altres històries de validació

Mites sobre Big Data



 

%d bloggers like this: